Salesforce and QuickBooks Desktop Integration Error
Salesforce and QuickBooks Desktop Integration Error: Application request to abort on Web connector.
Summary
We usually encounter this error:
Application request to aborton the Web connector, when the QuickBooks company file path is changed.
Problem
Whenever we try to trigger the sync using the Web Connector, the following error appears in the Web Connector status:
Application request to abortApplies To
Product/Service : DBSync Cloud Workflow
Versions: All versions supporting Salesforce-QBD integration
Operating Systems: Platform-independent (Cloud-based)
Databases / Connectors: Salesforce, QuickBooks Desktop
Applicable To: Quickbooks Desktop users
Solution
STEP 1: Download QuickBooks WebConnector to run this task
QuickBooks File: To know the path, open the QuickBooks app and press the function F2 (or Fn+F2) key from your keyboard. File path is mentioned in the File Information section.
QuickBooks Version: Choose the version as 2014 and more
Select the number of retry count, usually 2.
Save the setup.
STEP 2: Select the task to download QuickBooks WebConnector
Project Name: It will be the default current project
Task Name: Choose which task to be automated.
Click download as admin mode and singe user, and double click the .qwc file.
Make sure your QuickBooks Desktop file is opened
Select the option 'Yes, always; allow access even if QuickBooks is not running'. Then, select 'Admin' click on continue.
DBSync integration process will be added to your Quickbooks Web-Connector.
Once the process is added to the web-connector, add the DBSync account password in the Password section of the Web-Connector. Then press Enter and click yes.
STEP 3: Update Web Services
This allows to view the list of web services added to the QuickBooks.
STEP 4: Run the Web Service
Select the DBSync WebConnector application and click 'Update Selected'
The WebConnector will start updating the information and progress bar will show the status of completion.
Root Cause
If the QuickBooks company file path is changed on the client machine, the Web Connector will throw the error
during sync attempts, as it can no longer locate the file at the expected path


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