# Quickbooks Online disconnected with an error message in the logs

#### Summary

This article provides steps to troubleshoot and resolve the following Quickbooks online disconnected errors:

```
Error: QuickBooksRestV3Adapter Exception while Reseting OAuth Tokens
```

```
Error: Failed to process Transform and Write action Unable to authenticate connection to QuickBooks Online, Reconnect and try again
```

#### Problem

When syncing records between Salesforce and QuickBooks Online using DBSync, the process fails with the following error message:

```
QuickBooksRestV3Adapter Exception while Reseting OAuth Tokens
```

#### Applies To

* **Product/Service**: DBSync Cloud Workflow
* **Versions**: All versions supporting Salesforce-QBO integration
* **Operating Systems**: Platform-independent (Cloud-based)
* **Databases / Connectors**: Salesforce, QuickBooks Online

#### Solution

**Prerequisites**

* Admin access to DBSync
* Admin Access to the client’s QBO file.
* Admin login credentials for Quickbooks online for sign in.

#### &#x20;Steps

1. **Login To your DBSync Account**: Log in to your DBSync account.
2. **Open New Development Studio**: Click **New Development Studio** (Button at the right side). In the Cloud Workflow Development Studio, click the required project name to open it.
3. **Open Connectors**: Click **Connectors** on the left side of the window and then click project name Quickbooks connector.
4. **Reconnect QuickBooks**: Click **Would you like to reconnect?** --> **Connect to QuickBooks**. Login to your Quickbooks Online with the credentials.
5. **Validate and Save**: Click **Advanced Properties** next to Quick Set Up. **Validate** and **Save** the connection.

#### Root Cause

This issue arises when the Quickbooks login password has been changed.

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