Invalid Email Address format
Summary
The error “Invalid Email Address format Email Address does not conform to the syntax rules of RFC 822” occurs during sync when the provided email address is not passing the RFC 822 syntax rules. This article explains how to identify and resolve the issue.
Problem
When syncing records from Salesforce (or any source system) to QuickBooks Online via DBSync, the sync fails with the following error message:
Error: Invalid Email Address format Email Address does not conform to the syntax rules of RFC 822. Supplied value:Â [email protected]This typically indicates that the format of the email address is not passing the RFC 822 syntax rules.
Applies To
Product/Service: DBSync Cloud Workflow
Versions: All versions supporting Salesforce-QBO integration
Operating Systems: Platform-independent (Cloud-based)
Databases / Connectors: Salesforce, QuickBooks Online
Applicable To: “BillEmail” Address Mapping during Invoice Sync
Solution
Prerequisites:
Admin access to DBSync
Mapping access for the integration project
Access to Salesforce (Source) instance if required
Steps
Log in to the Salesforce (source) instance and open the record that is failing to sync with the above error.
Make sure the provided email address is the right format i.e, it passes the RFC 822 syntax rules
Once the format of the existing email address is corrected, try to re-sync the record.
Root Cause
Since the provided email address did not conform to RFC 822 syntax rules, QBO returned the error message
Invalid Email Address format: Email Address does not conform to RFC 822 syntax
which halted the sync.
Additional Information
https://stackoverflow.com/questions/18551707/what-is-the-rfc-822-format-for-the-email-addresses

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