> For the complete documentation index, see [llms.txt](https://docs.mydbsync.com/cloud-workflow/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://docs.mydbsync.com/cloud-workflow/troubleshooting/page-2/duplicate-name-exists.md).

# Duplicate name exists

#### Summary

This article provides steps to troubleshoot and resolve the Duplicate name exists error.

When a user is trying to integrate invoices from Salesforce to Invoices for QuickBooks Online, the synchronization does not work.&#x20;

```
Error: Duplicate name exists. The name supplied already exists. Another customer, vendor or employee is already using this name. Please use a different name.
```

This is because the already existing Account Name in Salesforce matches with the Customer Name in QuickBooks Online.&#x20;

As a result, QBO throws an error which can be seen in the DBSync logs.

#### Problem

When syncing records from Salesforce to QuickBooks Online via DBSync, the sync fails with the error message:&#x20;

```
Duplicate name exists error.
```

#### Applies To

* **Product/Service:** DBSync Cloud Workflow
* **Versions:** All versions supporting Salesforce-QBO integration
* **Operating Systems:** Platform-independent (Cloud-based)
* **Databases / Connectors:** Salesforce, QuickBooks Online
* **Applies To:** Customer mapping

#### Solution

**Prerequisites**

* Admin access to DBSync
* Access to the client’s QBO to verify existing name

**Steps**

1. Log in to Salesforce and open the Account.
2. Log in to QuickBooks and open the Customer.
3. Check the account name in QuickBooks whether it exists or not.
4. If the same account name exists in QuickBooks, modify the new account name in Salesforce as QuickBooks Online does **not support duplicate Customer Names**. After changes, the Customer will get created in QuickBooks.

#### Workaround (If Applicable)

QuickBooks Online does **not support duplicate Customer Names**. Ensure that the customer, vendor or employee is already using this name in QuickBooks Online. If yes, try to change the Account Name in Salesforce (say, using initials) and re-sync.

#### Root Cause

The already existing Account Name in Salesforce matches with the Customer Name in QuickBooks Online. As a result, QuickBooks Online throws an error which we are able to see in the DBSync logs.


---

# Agent Instructions
This documentation is published with GitBook. GitBook is the documentation platform designed so that both humans and AI agents can read, navigate, and reason over technical content effectively. Learn more at gitbook.com.

## Querying This Documentation
If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter, and the optional `goal` query parameter:

```
GET https://docs.mydbsync.com/cloud-workflow/troubleshooting/page-2/duplicate-name-exists.md?ask=<question>&goal=<endgoal>
```

`ask` is the immediate question: it should be specific, self-contained, and written in natural language.
`goal` is optional and describes the broader end goal you are ultimately trying to accomplish on behalf of the user. GitBook uses it to tailor the answer towards what is most useful for that goal.

The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
