# Change DBSync credentials in QuickBooks Desktop

#### Summary

This article provides steps on how to change DBSync credentials in the QuickBooks Desktop web connector.

This needs to be done when you change the DBsync credentials. Ensure that you update the credentials in the web connector as well.

#### Problem

When syncing records from Salesforce to QuickBooks via webconnector, the sync fails and you receive authentication failure error in QuickBooks Web Connector (QBWC)

When syncing records from Salesforce to QuickBooks via webconnector, the sync fails after changing the DBsync credentials with the error message:&#x20;

```
Authentication failed or wrong password entered. 
```

#### Applies To

* **Product/Service**: DBSync, QuickBooks Web Connector (QBWC)
* **Versions**:  All versions of QuickBooks and Web Connector
* **Operating Systems**: Windows Server environments
* **Databases / Connectors**: Salesforce, QuickBooks Desktop.
* **Applies To**: Multi-user QuickBooks environments

#### Solution

**Prerequisites:**

* Admin access to the QuickBooks company file
* Access to the hosting environment (if applicable)
* Admin access to DBSync

**Steps:**

1. Open the Quickbooks Desktop app → Login as “admin” user → Switch to single-user mode.&#x20;

{% hint style="info" %}
If you see **Switch to Multi-user Mode**, it means you are in Single user mode.
{% endhint %}

1. Click **App Management** and update web services.
2. Add the DBSync account password in the **Password** section of the Web-Connector. Then press **Enter**, and click **Yes**.

#### 6. Root Cause

The issue occurs because the credentials configured in DBSync and the Web Connector are no longer synchronized. When DBSync credentials are changed without updating the corresponding credentials in the Web Connector, authentication fails, preventing successful communication between the systems.


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://docs.mydbsync.com/cloud-workflow/troubleshooting/page-2/change-dbsync-credentials-in-quickbooks-desktop.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
